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About BCR Basic
About BCR Basic

Introduction and Overview

BCR Basic is a powerful call recording software program designed to 
record from any telephone on a BCM50 or BCM450 system running 
Release 5 software.

This unique new product built specifically for BCM offers a software-
based solution to run on a Windows PC with only a network connection 
to the BCM. No hardware is required to tap phone connections or 
trunks and no network monitoring is necessary.

BCR Basic allows you to record and log telephone calls directly onto a 
personal computer. The system generates digital call records that can 
be saved and allows you to easily recall, play back, archive, and share 
recorded conversations. You can also analyze and generate detailed 
reports of telephone activity.

System Description A BCR Basic system is comprised of a Windows-compatible application 
program installed on a PC that is connected to the same network as the 
BCM system. The BCM must have at least one license for Nortel 
Professional Call Recording active for the telephone extension (DN) 
being used for call recording.

BCR Basic works by automatically recording the telephone data 
associated with the recorded DN, including voice conversations, set 
display, and type of call (incoming, outgoing, or conference), in 
accordance with the Nortel Professional Call Recording rules set in BCM 
Element Manager.

BCR Basic can be installed on any Windows 7, Vista, Server 2003, XP, or 
2000 PC.

BCR Versions BCR Basic is designed for recording from a single telephone extension 
only.

A multi-user version of BCR Basic, called BCR Pro, is scheduled for 
release in Q2 2010. This version will allow recording from many 
extensions on one PC.

Terminals Supported • T7000 and M7000 Series Digital TDM Telephones
• 1100, 1200, and 2000 Series IP Phones
• IP Softphone 2050
• Analog

PC Requirements • Windows 7, Vista, Server 2003, XP, and 2000
• 1 GB Free Hard Drive Space (Recommended)

BCM Requirements • BCM50 or BCM450 running on Release 5
• Nortel Professional Call Recording license.
www.algosolutions.com 3
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Quick Start
Quick Start

Obtain and Activate License(s) for Nortel Professional Call Recording

Nortel Professional Call Recording licenses can be obtained from your 
authorized Nortel partner.

Configure BCM Element Manager

1. Open the Nortel Business Element Manager and connect to the 
BCM.

2. Go to the Task Navigation Panel, select the Configuration tab, and 
expand the Telephony Section.

3. Click on Call Recording.

4. Click on the Add button (located in the Professional Call Recording 
Configuration section) to open the Add Recording Rule dialog box.

• Enter the DN to be recorded.
• Select the Call Option (e.g. All calls)
• Set the destination (Where to send 

recording) to Computer.
• Enter the IP address of the computer on 

which BCR Basic will be installed, fol-
lowed by the port number 15050 (e.g. 
192.168.1.101,15050). If needed, 
please refer to “Finding your PC’s IP Address” on page 22.

• Uncheck the Call Tracking Only setting.
• Press OK to save and apply the rule.

Install the BCR Basic Application

1. BCR Basic can be downloaded from www.algosolutions.com/bcr
2. After downloading, run the BCR_Install.exe program on the PC you 

intend to use for call recording. The installation wizard will open to 
guide you through the installation process.
BCR Basic Installation and User Guide 4



Quick Start
3. Click Finish to complete the installation and launch BCR Basic.
4. When the interface opens, enter the DN 

of the BCM recording rule that you cre-
ated earlier. Then click OK to apply the 
setting. If later you need to change the 
DN, please refer to “Reset DN” on 
page 16.

Test out the System

Now that BCR Basic is installed, you can try the following for a test and 
quick introduction to the software.

Make a Call 1. Open BCR Basic by double-clicking the BCR Basic icon on the desk-
top.

2. Make a call. Notice the flashing Telephone icon which displays in 
the Call List View of BCR Basic. This lets you know that your call is 
being recorded successfully.

3. Finish your conversation and hang up.
4. A new call record should now appear in the Call List. Double-click 

on this new call to play back this call record. If you cannot hear any-
thing, check to see that your speakers or your headset are enabled.

Send an Email 5. Select the call record you created above (from the Call List), then 
click the Email icon from the BCR Basic toolbar. BCR Basic will auto-
matically open the email client configured for your PC and insert the 
call record as an attachment.

Close the Software 
Interface

6. Close the BCR Basic Interface by clicking on the  (Windows Close 
button). Note that the BCR Basic Interface does not need to be 
opened in order to record your conversations. The recording system 
runs in the background of your PC and displays an icon in the sys-
tem tray to indicate that it is active. To deactivate the recording, sim-
ply shut down the recording system from the BCR Basic Interface 
Tools menu (Tools>Recording System Commands>Shutdown) or 
the system tray icon right-click menu “Shutdown BCR Service” 
option.

When first running BCR Basic, some third party 
firewall programs might incorrectly flag that the 
program wants to access the internet. If this 
happens, simply allow these processes. For more 
information, please refer to “Firewall Issues” on 
page 21. 
www.algosolutions.com 5
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Software Overview
Software Overview
BCR Basic is made up of two different program components:

1. Interface program
2. Recording system

Interface Program

The BCR Basic Interface is the main program you, the user, will see and 
interact with. It is where you can set system parameters, and perform 
such functions as accessing, editing and emailing call record data, 
creating reports, and starting or stopping the Recording system. 
Depending on how you or your business operates, you may use the BCR 
Basic Interface constantly, occasionally, or hardly at all.

Startup To start the BCR Basic Interface, do one of the following:

• Double-click the BCR Basic icon on the desktop
• Choose Start>Programs>Algo>BCM Call Recorder>BCR Basic

• Double-click the system tray icon  (or right-click the icon, then 
choose Open BCR Basic)

Recording System

The Recording system is the background functionality of the BCR Basic 
program. When active, it operates continuously - whether you access 
the Interface program or not. In the background, it performs 
(depending on the system settings) such actions as:

• Automatically recording and logging calls
• Automatically filtering calls
• Logging call activity, and
• Automatically deleting calls

The Recording system can be turned on or off through the BCR Basic 
Interface (Tools>Recording System Commands) or by right-clicking the 
system tray icon (if enabled) and choosing Shut down recording.

Note that exiting the BCR Basic Interface does NOT shut down the 
recording system.
BCR Basic Installation and User Guide 6



Getting Familiar
Getting Familiar
The BCR Basic Interface is made up of three main views:

• Call List (default startup view)
• Statistics
• Call Finder

Common Elements

There are several common elements to the View windows in the BCR 
Basic Interface. These include:

• The Drop-Down Menu at the top of the screen
• Toolbar
• View Tabs
• Context Menu
• Call Playback Panel

Drop-Down Menu

The drop-down menu provides a consistent navigation system 
throughout the BCR Basic Interface, available from all three main views.

Toolbar

The Toolbar contains icons for quick feature selection. For detailed 
information on these icons, please refer to “Description of Call Record 
Functions” on page 12. The Toolbar icons are greyed out when a call 
record is not actively selected.

View Tabs  

The View Tabs make it easy to switch between Views. Simply click on the 
tabs to change to the selected view.
www.algosolutions.com 7
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Getting Familiar
Context Menu A context (right-click) menu is also available in the 
Call List and Call Finder Views when a call record is 
selected.

Player Panel

The Player Panel is for playing back selected call records. For more 
information on this panel, please refer to “Player” on page 9.

Call List View

The Call List View is the primary screen used in BCR Basic. The view is 
comprised of three main sections:

1. Current Call / Telephone Status Display
2. Recent Calls
3. Player

Current Call / 
Telephone Status 
Display Section

This section displays real-time information about any current call in 
progress. From here, you can perform various functions related to the 
current call. More specifically, this section displays:

• Status of telephone recording activity (the telephone icon flashes 
when the recording is set to be saved in the database)

• Telephone Set Display data (Caller ID or dialed number)

This section also allows you to:

Current Call

Recent Calls
Section

Section

Player
Section
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Getting Familiar
• Enter and save comments while on the current call
• Toggle recording (used to save only portions of a call recording)

Recent Calls List This section is where your most recent call records are (or will be) listed 
and from where you can perform various functions related to those call 
records.

The Recent Calls list displays all of the relevant information related to 
each of your call records. This includes the start time, duration, set 
display, user-entered comments, type of call, protection status, call 
record filename, and the file format (wma or wav).

Key Features • Clicking on each column heading automatically sorts the call 
records. You can use this feature to easily sort or locate calls.

• Each column is resizable. Just click on the border between two col-
umn headings and drag to the desired size.

• By selecting a call record and right-clicking, you can play or email 
the record, add or edit comments, edit set display text, delete the 
record, protect the record from automatic deletion (or unprotect it), 
save the record as an external file, or copy the record to another 
directory.

• You can access the Quick Find function (by clicking the Quick Find 
icon or by selecting a call record, right-clicking and choosing Quick 
Find) that allows you to quickly search through all calls in the Call 
List View. Note that for full search capabilities on all calls in the BCR 
Basic database, use the Call Finder function (see “Call Finder View” 
on page 11).

• Because BCR Basic call records are Windows files, they can be 
selected, copied, or dragged-and-dropped from the Call List View 
to different folders, back-up media, emails, or your desktop.

Player The Player Panel provides call record playback functionality. To use the 
Player, first select a call record from the list of calls, then click the play 
button. Once playing, you can pause or stop the playback, drag the 
playback slider to skip to a different section of the call, and adjust the 
playback volume.

Use the Player Panel to control and monitor the playback of a selected 
call record. The Player Panel includes the following information and 
controls:

Playback File Provides the name of the currently selected call record file.

Play Speed
SliderVolume Slider

Play
Pause

Stop

Playback File

Playback
Progress
Slider

Playback Progress 
Summary

Playback 
Buttons
www.algosolutions.com 9
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Getting Familiar
Playback Progress
Slider

Provides a visual timeline indication of the playback progress and also 
allows you to quickly jump ahead or back to sections of the call record 
file. To use the slider, left-click the slider, hold the mouse button down, 
then drag the slider to the portion of the call record you want to listen 
to. Alternatively, you can left-click anywhere on the timeline to make the 
playback jump forward or backward.

Playback Progress
Summary

Provides information of how long the current call record file is and how 
far along the playback has progressed (in minutes and seconds).

Playback Buttons Use the basic Play, Pause, and Stop buttons to control the playback of 
the call record file.

Volume Slider Drag the volume slider to control the playback volume of the call record 
file. If you are unable to generate enough volume, try adjusting your PC 
audio settings or turn up the volume controls on your speakers.

Play Speed Slider This control allows you adjust the speed of the playback of the call 
record file with minimal effect on the clarity of the content. A slow speed 
is useful if you have to type out a written record of a file and want to 
ensure the conversation is slow enough for you to keep up. A faster 
speed allows you to quickly scan through a file to find a particular piece 
of information.

Statistics View

BCR Basic keeps track of your telephone usage and can provide some 
interesting and useful statistical information. These statistics can be 
generated from all calls in the database or based on a specified time 
period. 

To access this information:

1. Click the Statistics tab, or select View>Call Statistics.
2. Choose the desired From and To dates.
3. Click the Generate statistics report button.

Available statistical information includes:
BCR Basic Installation and User Guide 10



Getting Familiar
• Number of telephone calls made outbound
• Number of telephone call received
• Number of conference calls
• Longest, shortest, and oldest call, and
• Average call duration

Data appearing on screen can be exported to Microsoft Excel® using 
the Export to Excel feature found in the Tools menu.

Call Finder View

Searching is probably one of the most powerful features of BCR Basic. 
Clicking the Call Finder icon brings up a menu of search options that 
can be used, in combination, to very quickly find the exact call record 
you need.

Call Finder Search 
Options

Call records can be searched by any combination of the following:

• Date range
• Call duration
• Set Display - dialed number or Caller ID string match
• Comment text match
• Call type - inbound/outbound/conference

Records that meet the search criteria will be listed in the Call Finder 
View. This view is similar in functionality to the Recent Calls section of 
the Call List View, listing all of the relevant information related to each 
call, and allowing you to perform various functions related to those call 
records (playing, emailing, protecting, etc.)
www.algosolutions.com 11
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Description of Call Record Functions
Description of Call Record Functions
BCR Basic provides numerous functions for working with the call records 
you collect. These are:

• Email
• Comments
• Quick Find
• Delete
• Protect / Unprotect
• Edit Set Display
• Save As
• Copy

There are several ways to access these functions from either the Call List 
or Call Finder views:

• Select a call record, right-click your mouse, then choose from the 
drop-down list

• Select Edit from the main menu bar, then choose from the drop-
down list (only the edit functions are available from this method)

• Use the function buttons from the main toolbar

Email

Call records may be easily 
emailed as attachments by 
simply highlighting one or 
more call records and 
choosing the Email function. 
Standard Windows controls 
work in the Call List View to 
select multiple call records - 
for example, holding the CTRL 
key while clicking the selected 
call records you wish to email.

BCR Basic will, by default, use Microsoft Outlook or Outlook Express to 
compose and send emails.

Clicking the Email icon will open your email software and automatically 
insert as attachments the call records you selected. In addition, the call 
detail and comments are inserted into the text body. BCR Basic will also 
include an “Algo Recorded” line of text. Of course we hope you will help 
us promote our product, but this text line may be deleted manually and 
set to not be displayed by unchecking the Display Recorded message 
checkbox in Tools>Options>Email.
BCR Basic Installation and User Guide 12



Description of Call Record Functions
Any of the automatically inserted text may, of course, be edited or 
deleted if you do not wish to share this information with your recipient. 
Keep in mind that this information is also embedded in the audio file 
(e.g. comment text), but will not be retrieved by Windows Media Player.

Add Comments

Adding comments to a call record 
not only helps summarize the 
contents of a call but also makes 
search and retrieval much easier at 
a later date.

Anytime while recording a call, comments (up to 200 characters) can be 
typed into the Comment bar in the Current Call section of the Call List 
View.

Once a call is saved, comments may be added or edited by selecting 
the Comments function. You can then add or edit text in the Comment 
text box.

Comments are embedded into call records, just like Caller ID and other 
data, to be retrieved by BCR Basic.

Quick Find

4.

The Quick Find function allows you to search all the fields in the dis-
played call list in either the Call List View or Call Finder View. The 
function highlights any call records, from any field, that match the 
text entered in the Quick Find search box.

Delete

The Delete function allows you to delete one or more call records that 
have been selected in the Call List View. Note that the Delete function 
will not delete protected records. To delete a protected record, first 
unprotect the record, then delete it.

Don't forget to change the subject line of your 
email to something relevant to your recipient!

For an advanced search, or to find older call 
records, user the Call Finder tab instead.
www.algosolutions.com 13
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Tools Menu
Protect/Unprotect

Allows you to protect a call record so that it cannot be deleted within 
BCR Basic. 

To protect a call record, select the record then choose the Protect 
function. To manually delete a protected call record, first unprotect it, 
then delete it.

Edit Set Display

Allows you to edit the automatically-generated text in a call record’s set 
display field, up to a maximum of 200 characters.

Save As

Allows you to save a call record under a different name or to a different 
location on your computer or storage media.

Copy

Allows you to copy selected call records to a different directory on your 
computer or storage media. To use this function, first select the call 
records of interest from the Call List or Call Finder views, choose Copy, 
then select the target folder to copy to.

Tools Menu

Recording System Commands
BCR Basic Installation and User Guide 14



Tools Menu
To shutdown or restart BCR Basic, choose Tools> Recording System 
Commands.

Export Data to Excel

BCR Basic includes an Excel Export function (Tools>Export data to Excel) 
that allows you to produce formatted reports in Microsoft Excel based 
on data in an active Call List, Call Statistics, or Call Finder View.

As an example, you could generate a call statistics report of weekly call 
data, then export the data to Excel for formatting and printing.

Another example is to create a Call Finder window displaying all 
business calls related to a certain client during the last month. This 
report could then be exported to Excel and used to support invoicing or 
client communications.

Repair Database

BCR Basic includes a database maintenance function that allows 
reconstruction of the call record database if some records have become 
corrupted, or been manually added or deleted from outside of BCR 
Basic.
www.algosolutions.com 15
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Tools Menu
To repair the database, choose Tools>Repair Database, then select one 
or more monthly folders of call data. Each folder is identified by the 
year-month format of yyyymm. For example, to repair the database 
holding calls for January 2010, select the 201001 folder.

Once activated, this feature reads all the call record files in the selected 
directories to rebuild the call database used for searches and displays.

Send Logs

This option is used to gather all the 
BCR Basic logs and settings and zip 
them into a file that can be sent 
easily to Algo support for 
troubleshooting purposes.

Note that before being able to use 
this feature, you must first have 
obtained/purchased an Algo 
support case number.

Reset DN

If you need to change the DN you want BCR Basic to record from, use 
the Reset DN function. The function works by resetting the DN 
information and shutting down the BCR Basic Interface. After this, you 
must restart BCR Basic and re-enter the new DN. Note that in doing so, 
your existing call records will be unaffected and no information will be 
lost.
BCR Basic Installation and User Guide 16
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Configuring BCR Basic (Options Description)

Numerous configuration options for BCR Basic are available by 
accessing Tools>Options from the main menu.

The following sections describe these options:

Call List View

Display Settings Display Settings control how many recent calls will be displayed in the 
Call List View’s Recent Calls list. The display of calls can be limited by:

• Number of calls
• Period of time

For example, if the option for “10 days” is selected, the Call List View 
will only display call records from the last 10 days.

Note that the Call List View only lists recent calls and the complete list of 
calls in the BCR Basic database can still be accessed using the Call 
Finder.

Date Time Format Set the time and date format in the program by selecting from the drop-
down list.

To get a complete listing of all calls, use the Call 
Finder and enter a “blank” search with no 
parameters.
www.algosolutions.com 17
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Configuring BCR Basic (Options Description)
Recording Format

Encoding This option allows you to set the encoding format used for call record 
file creation. You can change the audio quality of call records by 
selecting one of two recording formats: WMA or uncompressed WAV.

For the WMA recording format, the default encoding profile is Best 
Audio Compression which provides a good balance between audio 
quality and compression level. It is also the most space efficient format. 
The other option, Best Audio Quality, provides better audio quality but 
requires more storage disk space.

Encoding and Storage 
Requirements

BCR Basic’s call record files use 3 MB, 5 MB, or 60 MB of hard drive 
space per hour of conversation (depending on encoding format 
selected).

The following table summarizes how long you can record calls for 
based on different hard disk capacities and encoding settings:

*Based on 20 hours of recording per week

Table 1: Recording Capacity*

Hard Drive 
Capacity
(in GB)

WMA - Best 
Audio 

Compression

WMA Best 
Audio Quality

WAV - 
Uncompressed

3 MB/Hour 5 MB/Hour 60 MB/Hour

1 4 months 2.5 months 6 days

5 1.5 years 1 year 1 month

10 3 years 2 years 2 months

50 15 years 10 years 10 months

100 30 years 20 years 1.5 years
BCR Basic Installation and User Guide 18



Configuring BCR Basic (Options Description)
Call Storage

Call Storage This option allows you to set or change the directory where call records 
are stored. The default storage directory is 
C:\Program Files\Algo\BCR\Database\

Network Drive 
Windows User Access

In order to select a mapped drive as the root of the call storage 
directory, you will have to enter the Windows User Login information of 
the currently logged in user to allow BCR Basic to access it. Note: The 
Windows User Login must have read and write privileges to the selected 
mapped drive.

Email

Allows you to automatically include Email signature text into any emails 
sent from BCR Basic.

BCR Basic will create its database folder structure 
inside the selected folder for call record storage. 
This is done following a naming convention of 
year-month
 (i.e. “.\domain\stn001\200907\”)
www.algosolutions.com 19
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Configuring BCR Basic (Options Description)
This option also allows you to disable the default “Algo Recorded” 
message displayed in the emails.

Log Level

Sets the level of detail of software activity logs generated by BCR Basic. 
The Normal setting is the default for regular system operation.

Note: Debug and Troubleshoot settings should only be used on the 
advice of Algo technical support personnel.
BCR Basic Installation and User Guide 20
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Appendix

Legality of Call Recording

Country and Regional 
Laws Govern

The legality of recording calls depends on where you live or work. 
Usually calls may be recorded legally either by single-party or two-party 
consent.

This means it is often illegal for you to record calls between two other 
parties if neither party knows that the call is being recorded. In Canada, 
a recording is generally legal if at least one party on the call knows the 
call is being recorded. In the USA, this varies from State to State.

When using BCR Basic, Algo recommends always informing the other 
party(s) that the call is being recorded.

Legal Advice Algo does not advise on the legality of recording nor take responsibility 
for regulations that vary by location and may change with time. 
Information abounds on the internet from multiple sources and several 
websites (such as www.rcfp.org/taping) offer up-to-date information by 
location and include legislative language for your area. It’s also a good 
idea to consult your lawyer.

Firewall Issues

BCR Basic processes employ TCP/IP (Internet) technology to 
communicate with each other. Although this communication only occurs 
within the computer/machine boundary, some third party firewall 
software might inaccurately flag that these processes want to access the 
internet. In these cases, simply allow these processes:

• BCR_Agent.exe
• BCR_StnViewer.exe
• *BCR_Recorder.exe

When prompted, allow these programs to have internet access and 
check, “Do not ask again” or “Remember this setting” to store this 
configuration. 

* In some cases, your operating system may block BCR_Recorder.exe 
and NOT prompt you to allow this process. This will prevent you from 
receiving calls. In that case, you must manually unblock the process in 
your Firewall. 

As an example, if you are using Windows Firewall, please follow these 
steps to allow the BCR_Recorder.exe process:

If you ARE prompted to allow the above 
processes by your firewall software, we would 
appreciate knowing about it (including firewall 
software version and Operating System).
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http://www.algosolutions.com


Product Feedback
1. Open up Windows Control Panel
2. Choose Windows Firewall
3. Click the Exceptions Tab
4. Select Add Program
5. Select Browse
6. Navigate to C:/Program Files/Algo/BCR/exe then select 

BCR_Recorder.exe
7. Select Open
8. Accept and close out the various windows.

Finding your PC’s IP Address

You can find your PC’s IP address by displaying the Windows IP 
Configuration information from the Command Prompt. To open the 
Command Prompt:

• For Windows XP: Click Start, then Run. In the Open box, type cmd, 
then click OK.

• For Windows 7 and Vista: Click Start, then, in the Start Search box 
(just under “All Programs”), type cmd and press Enter.

Once the Command Prompt is open, type ipconfig then press Enter. This 
will display the Windows IP Configuration information. You’ll see your IP 
address listed right above the subnet mask. It may be listed as an “IPv4” 
address. When finished, close the Command Prompt.

Product Feedback
Algo is always interested in receiving feedback on its products.

Please send any comments or suggestions to 
bcrfeedback@algosolutions.com

We appreciate it, thank-you!
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